[Logo] Terracotta Discussion Forums
  [Search] Search   [Recent Topics] Recent Topics   [Members]  Member Listing   [Groups] Back to home page 
[Register] Register / 
[Login] Login 
[Expert]
Quartz 'phoning home' at start up  XML
Forum Index -> Quartz
Author Message
hobbsjd

neo

Joined: 03/31/2010 06:05:55
Messages: 3
Offline

I noticed that a Tomcat instance was freezing at start just after starting up a Scheduler. I fired up Wireshark to try to see if it was trying to connect to something and failing (suspecting my database connection or something) and found that Quartz was attempting to reach back to terracotta.org at startup. This request was rejected by our corporate firewall, apparently resulting in a freeze.

When I hit the URL manually (from another host that the firewall lets thru), the URL appears to return quartz version information.

How can I disable quartz 1.7.3 from 'phoning home' in this manner?

From Tomcat's output :

2010-03-31 08:50:00,110 [main] - [INFO ] - [simpl.SimpleThreadPool] - Job execution threads will use class loader of thread: main
2010-03-31 08:50:00,188 [main] - [INFO ] - [core.SchedulerSignalerImpl] - Initialized Scheduler Signaller of type: class org.quartz.core.SchedulerSignalerImpl
2010-03-31 08:50:00,188 [main] - [INFO ] - [core.QuartzScheduler] - Quartz Scheduler v.1.7.3 created.
2010-03-31 08:50:00,188 [main] - [INFO ] - [simpl.RAMJobStore] - RAMJobStore initialized.
2010-03-31 08:50:00,188 [main] - [INFO ] - [impl.StdSchedulerFactory] - Quartz scheduler 'XXXQuartzScheduler' initialized from default resource file in Quartz package: 'quartz.properties'
2010-03-31 08:50:00,235 [main] - [INFO ] - [impl.StdSchedulerFactory] - Quartz scheduler version: 1.7.3
2010-03-31 08:50:00,235 [main] - [INFO ] - [core.QuartzScheduler] - Scheduler XXXQuartzScheduler_$_NON_CLUSTERED started.
 


From Wireshark's 'Follow TCP Stream' feature:

GET /kit/reflector?kitID=quartz&pageID=update.properties&id=-1408234938&os-name=Windows+XP&jvm-name=Java+HotSpot%28TM%29+Server+VM&jvm-version=1.6.0_16&platform=x86&tc-version=1.7.3&tc-product=Quartz&source=Quartz&uptime-secs=0&patch=UNKNOWN HTTP/1.1

User-Agent: Java/1.6.0_16
Host: www.terracotta.org
Accept: text/html, image/gif, image/jpeg, *; q=.2, */*; q=.2
Connection: keep-alive
 

hhuynh

cherubim

Joined: 06/16/2006 11:54:06
Messages: 759
Offline

-Dorg.terracotta.quartz.skipUpdateCheck=true will do the trick.
teck

seraphim
[Avatar]
Joined: 05/24/2006 15:03:25
Messages: 1127
Offline

There should be no blocking/freeze associated with the update checker. If you suspect it is causing interference to the application, please take a thread dump dump of your process to see what is going on.

Tim Eck (terracotta engineer)
hobbsjd

neo

Joined: 03/31/2010 06:05:55
Messages: 3
Offline

The JVM arg stopped the HTTP hit at startup, but something is still freezing. I'll look into that deeper.

Is there any way to set this from quartz.properties? I really dislike having to set JVM args on Tomcat like this.

When did this update check make it into Quartz? I don't remember it doing that in older versions I've used.
hhuynh

cherubim

Joined: 06/16/2006 11:54:06
Messages: 759
Offline

there's no way to stop it in quartz properties yet but that's a good suggestion.
hobbsjd

neo

Joined: 03/31/2010 06:05:55
Messages: 3
Offline

For the record it was freezing up trying to get to a table... somebody had an exclusive on it. Thanks for the help on turning off the version check, fellas.
rlovtang

neo

Joined: 04/26/2010 03:11:50
Messages: 2
Offline

According to Jira issue QTZ-29 http://jira.terracotta.org/jira/browse/QTZ-29 Quartz 1.8 now has a quartz property "org.quartz.scheduler.skipUpdateCheck"

However, I cant get this to work, and when looking at the 1.8 source of org.quartz.utils.UpdateChecker I can't find any references to this quartz property.
jhouse

seraphim
[Avatar]
Joined: 11/06/2009 15:29:56
Messages: 1703
Offline


The property works fine for me.

The property is not on the UpdateChecker class, it's on StdSchedulerFactory -- which prevents an UpdateChecker from being created.

rlovtang

neo

Joined: 04/26/2010 03:11:50
Messages: 2
Offline

My fault, quartz.properties wasn't picked up because I configure Quartz with spring.
Added the property to the schedulerFactoryBean bean, and the update check was disabled.

The jvm arg is checked in the UpdateChecker class, that's why it didn't strike me to look anywhere else ;)
ArulSa

neo

Joined: 10/04/2010 23:52:08
Messages: 3
Offline

Hi All.. I am also facing the same problem. I have tried using the properties with spring bean and configuring property alone to spring bean. Neither worked for me.

Could you please help on this?
veita

neo

Joined: 11/09/2010 02:54:36
Messages: 1
Offline

Update checks really do not make sense in server environments. Moreover, phoning home is a source of problems and too close to malware behaviour. We just had a customer complaint about this.

Please consider changing to an opt-in policy for the update checker.
 
Forum Index -> Quartz
Go to:   
Powered by JForum 2.1.7 © JForum Team